OpenSSL-Sicherheitslücken und andere Bugs in PHP beseitigt

Die Autoren von PHP haben zwei neue Versionen der Skriptsprache herausgebracht, die eine Reihe von Fehlern ausbessert, inklusive zwei Sicherheitslücken in der Komponente OpenSSL. Die Versionen 5.4.28 und 5.5.12 enthalten beide das wichtige Patch. Zudem wird über ein Dutzend anderer Lücken gestopft.

Das Patch für die OpenSSL-Schwachstellen ist sowohl in PHP 5.4.28 als auch in der Version 5.5.12 enthalten. In beiden Versionen wird zudem eine Reihe anderer Lücken geschlossen, unter anderem CVE-2014-0185, ein Fehler, der zur Privilegien-Eskalation führen kann, d.h. er könnte es einem Angreifer ermöglichen, in bestimmten Situationen unwillkürlichen Code auszuführen.

“Sowohl die Default-Einstellung als auch die kompilierten Defaults in sapi/fpm führen zu Konfigurationen, die es jedem Nutzer mit Rechten problemlos ermöglichen, sich mit einem UNIX-Socket zu verbinden, um willkürlichen Code mit der Erlaubnis des fpmu-Users auszuführen” heißt es in einer Beschreibung des Bugs.

“Ein typisches Szenario für dieses Problem sieht folgendermaßen aus:

– eine virtuelle Umgebung mit mehreren fpm-Pools, die mit unterschiedlichen Zugangsrechten laufen (user1, user2, …)

– user1 kann problemlos Code als user2 ausführen, indem er vorgibt, ein FastCGI-Client zu sein und sich (beispielsweise) mit /var/run/php-fpm.user1.sock verbindet”, heißt es in der Beschreibung.

Den Nutzern beider PHP-Versionen wird empfohlen, so schnell wie möglich auf die reparierten Versionen zu aktualisieren, um sich vor potentiellen Attacken zu schützen.

Quelle: threatpost

Ähnliche Beiträge

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.